wiki:Internal/OpenFlow/SwitchConfiguration

Version 5 (modified by akoshibe, 15 years ago) ( diff )

Configuring the NEC Switch

Although configuring the NEC switch is pretty intuitive if you have worked with Cisco switches, some aspects of configuring them might require digging through the Japanese manuals to find.

Overview

All configuration steps assume privileged mode.
The configuration for the following topics are covered here:

  • Undoing configurations
  • DHCP/BootP relay agent/IP helper

Undoing Configurations

Most of the time, just adding the command no to the beginning of what you see when you do the command show configuration will suffice for undoing configurations, but occasionally you get something like this:

(config)# no vlan 4
vlan : Can't delete this configuration referred by other configuration.

This happens when the configs for an interface that you are trying to delete are associated with something else; you need to undo any configurations associated with an interface before you can delete it. In this particular case, VLAN 4 is associated with port 0/27, and you need to undo the configurations to port 0/27 that have to do with vlan 4 before you can get rid of it.

!(config)# int gi 0/27
!(config-if)# sh
interface gigabitethernet 0/27
  switchport mode access
  switchport access vlan 4
!
!(config-if)# no sw acc vlan 4
!(config-if)# exit
!(config)# no vlan 4
!(config)# save

DHCP/BootP relay agent/IP helper (6/28)

This is a translation from the online NEC guide.

  1. set up VLAN and associated port. Assign static IP address to port. This is the vlan on which the DHCP clients live.
    (config)# vlan 2
    (config-vlan)# exit
    (config)# interface gigabitethernet 0/5
    (config-if)# switchport mode access
    (config-if)# switchport access vlan 2
    (config-if)# exit
    (config)# interface vlan 2
    (config-if)# ip address 10.1.0.1 255.255.0.0
    (config-if)# exit
    
  1. Next, set up the VLAN and interface connected to the DHCP server.
    (config)# vlan 3
    (config-vlan)# exit
    (config)# interface gigabitethernet 0/7
    (config-if)# switchport mode access
    (config-if)# switchport access vlan 3
    (config-if)# exit
    (config)# interface vlan 3
    (config-if)# ip address 20.1.0.1 255.255.0.0
    (config-if)# exit
    
  1. set the DHCP server's address as the helper address.
    (config)# interface vlan 2
    (config-if)# ip helper-address 20.1.0.10
    (config-if)# exit
    

Note: See TracWiki for help on using the wiki.