wiki:Internal/OpenFlow/SwitchConfiguration

Version 6 (modified by akoshibe, 15 years ago) ( diff )

Configuring the NEC Switch

Although configuring the NEC switch is pretty intuitive if you have worked with Cisco switches, some aspects of configuring them might require digging through the Japanese manuals to find.

Overview

All configuration steps assume privileged mode.
The configuration for the following topics are covered here:

  • Undoing configurations
  • DHCP/BootP relay agent/IP helper

Undoing Configurations

Most of the time, just adding the command no to the beginning of what you see when you do the command show configuration will suffice for undoing configurations, but occasionally you get some message that can be a tad cryptic.

getting rid of telnet VLAN 4

VLAN 4 was the result of initial telnet configs until we realized we wanted to use Network VLAN 1 for telnet purposes. It was made so that port 0/27 was assigned to VLAN 4 so you can telnet using that port. You get this error if you try to remove VLAN 4 straight up:

(config)# no vlan 4
vlan : Can't delete this configuration referred by other configuration.

and you need to undo the configurations to port 0/27 that have to do with vlan 4 before you can get rid of it.

!(config)# int gi 0/27
!(config-if)# sh
interface gigabitethernet 0/27
  switchport mode access
  switchport access vlan 4
!
!(config-if)# no sw acc vlan 4
!(config-if)# exit
!(config)# no vlan 4
!(config)# save
interface vlan 3
  ip address 192.168.5.5 255.255.255.0
  ip helper-address 192.168.5.1
!
(config-if)# no  ip address 192.168.5.5 255.255.255.0
interface : IP interface is not defined.

in above circumstance, type "no ip helper-address" at the CLI before trying to remove ip address.

Command ppupdate for updating firmware, not actually needed (6/15)

The manual specified the command ppupdate for updating the firmware. This command copies new firmware (i.e. downloaded with ftp) on to the switch's flash memory. parameters usable:

ppupdate [test][no-display][-f][no-reload]<file name>

  • test - only tests firmware, but doesn't update the firmware
  • no-display - does not show status messages while firmware is being updated
  • -f - update without confirmation
  • no-reload - does not reboot switch after update, so changes take place after next restart
  • file-name - the firmware, usually named k.img

DHCP/BootP relay agent/IP helper (6/28)

This is a translation from the online NEC guide.

  1. set up VLAN and associated port. Assign static IP address to port. This is the vlan on which the DHCP clients live.
    (config)# vlan 2
    (config-vlan)# exit
    (config)# interface gigabitethernet 0/5
    (config-if)# switchport mode access
    (config-if)# switchport access vlan 2
    (config-if)# exit
    (config)# interface vlan 2
    (config-if)# ip address 10.1.0.1 255.255.0.0
    (config-if)# exit
    
  1. Next, set up the VLAN and interface connected to the DHCP server.
    (config)# vlan 3
    (config-vlan)# exit
    (config)# interface gigabitethernet 0/7
    (config-if)# switchport mode access
    (config-if)# switchport access vlan 3
    (config-if)# exit
    (config)# interface vlan 3
    (config-if)# ip address 20.1.0.1 255.255.0.0
    (config-if)# exit
    
  1. set the DHCP server's address as the helper address.
    (config)# interface vlan 2
    (config-if)# ip helper-address 20.1.0.10
    (config-if)# exit
    

Note: See TracWiki for help on using the wiki.